Jump to content





Recommended Posts

it wants to run as if it is on cruise but its not. something will happen and it goes back to normal   help

Share this post


Link to post
Share on other sites

You mean the engine is running but your car will not move?

Share this post


Link to post
Share on other sites

If you mean it’s accelerating when you’re not touching the pedal it could be the pedal assembly or the throttle body.

Share this post


Link to post
Share on other sites
Posted (edited)

thank you kirby it runs fine but you don't have to use the pedal(like its on cruise), sometimes it gains speed and sometimes something turns on or off and it all goes back to normal.been chasing this for a while. it has trouble downshifting and will stall when brought to a stop. cleaned throttle body, maf,air cleaner, replaced iac and pcv. still same problem. it's got me so far

Edited by wayne porter
spelling

Share this post


Link to post
Share on other sites
On 8/26/2021 at 4:07 AM, rethorn said:

You mean the engine is running but your car will not move?

it runs fine.takes off and gets to speed but when you let off the pedal lt doesn't deselerate. acts as on cruise. then it won't downshift right and will stall when stopped. refires right away. got me so far. any ideas?

Share this post


Link to post
Share on other sites

Sounds like the throttle body is bad.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×